GrooveOnBeat

Members
  • Content count

    82
  • Joined

  • Last visited

Community Reputation

1 Neutral

About GrooveOnBeat

  • Rank
    Advanced Member
  1. All is working now. Thanks!
  2. It is currently set on the domain level. Does that have to be set on a global level? php.ini was set to allow_url_fopen=on. Still getting the error.
  3. The server-side appears to check out ok. The private key matches. SSL key, certificate, and CA Bundle matches. port is open. allow_url_fopen is set to yes. Is there anything else that needs to be checked on the server-side? Is there anything that needs to be checked on the forum/babble side?
  4. Hi Michael, PHP 7 Recently upgraded PHP. After that I get these errors. Reset keys, stopped and restarted node.js. What works: Chat and online list What does not work: notifications (of any kind) ElephantIO\Exception\ServerConnectionFailureException 0: An error occurred while trying to establish a connection to the server #0 /home/site/public_html/forums/applications/babble/sources/3rdparty/vendor/wisembly/elephant.io/src/Engine/SocketIO/Version1X.php(48): ElephantIO\Engine\SocketIO\Version1X->handshake() #1 /home/site/public_html/forums/applications/babble/sources/3rdparty/vendor/wisembly/elephant.io/src/Client.php(60): ElephantIO\Engine\SocketIO\Version1X->connect() #2 /home/site/public_html/forums/applications/babble/sources/Sockets/Sockets.php(207): ElephantIO\Client->initialize() #3 /home/site/public_html/forums/applications/babble/modules/front/view/view.php(544): IPS\babble\_Sockets->connectedOnline() #4 [internal function]: IPS\babble\modules\front\view\_view->connectOnline() #5 /home/site/public_html/forums/system/Dispatcher/Controller.php(85): call_user_func(Array) #6 /home/site/public_html/forums/applications/babble/modules/front/view/view.php(255): IPS\Dispatcher\_Controller->execute() #7 /home/site/public_html/forums/system/Dispatcher/Dispatcher.php(129): IPS\babble\modules\front\view\_view->execute() #8 /home/site/public_html/forums/index.php(13): IPS\_Dispatcher->run() #9 {main} #0 /home/site/public_html/forums/applications/babble/sources/Sockets/Sockets.php(253): IPS\_Log::log('ElephantIO\\Exce...') #1 /home/site/public_html/forums/applications/babble/modules/front/view/view.php(544): IPS\babble\_Sockets->connectedOnline() #2 [internal function]: IPS\babble\modules\front\view\_view->connectOnline() #3 /home/site/public_html/forums/system/Dispatcher/Controller.php(85): call_user_func(Array) #4 /home/site/public_html/forums/applications/babble/modules/front/view/view.php(255): IPS\Dispatcher\_Controller->execute() #5 /home/site/public_html/forums/system/Dispatcher/Dispatcher.php(129): IPS\babble\modules\front\view\_view->execute() #6 /home/site/public_html/forums/index.php(13): IPS\_Dispatcher->run() #7 {main}
  5. I perfectly understand giving ETA's. You do great work so I'm sure when something is ready you'll let us know.
  6. I may have missed it, but what is the ETA for version 3? I'd like to try it out in Beta if possible. As long as it doesn't break the forum, haha. If there are Beta testers, any requirements?
  7. Error type "uncaught_exception" happens when searching in Babble... SELECT count(*) FROM `babble_messages` WHERE messages_room=1 and ( ( ( FIND_IN_SET(7,messages_perms) OR FIND_IN_SET(11,messages_perms) OR FIND_IN_SET(12,messages_perms) ) ) OR messages_perms="*" ) and messages_announcement !=1 and messages_is_pm = 0 and ( messages_muted=2 OR ( messages_muted=1 and messages_member=5 ) ) and messages_msg LIKE "%x%" and ( ) IPS\Db\Exception: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1 (1064) #0 /home/x/public_html/x/system/Db/Select.php(346): IPS\_Db->preparedQuery('SELECT count(*)...', Array) #1 /home/x/public_html/x/system/Db/Select.php(402): IPS\Db\_Select->runQuery() #2 /home/x/public_html/x/system/Db/Select.php(329): IPS\Db\_Select->rewind() #3 /home/x/public_html/x/system/Helpers/Table/Db.php(279): IPS\Db\_Select->first() #4 /home/x/public_html/x/system/Helpers/Table/Table.php(424): IPS\Helpers\Table\_Db->getRows(Array) #5 /home/x/public_html/x/applications/babble/sources/Rooms/Rooms.php(231): IPS\Helpers\Table\_Table->__toString() #6 /home/x/public_html/x/applications/babble/modules/front/view/view.php(688): IPS\babble\_Rooms::buildRoomArchive(Object(IPS\babble\Rooms\Room)) #7 [internal function]: IPS\babble\modules\front\view\_view->roomArchive() #8 /home/x/public_html/x/system/Dispatcher/Controller.php(85): call_user_func(Array) #9 /home/x/public_html/x/applications/babble/modules/front/view/view.php(255): IPS\Dispatcher\_Controller->execute() #10 /home/x/public_html/x/system/Dispatcher/Dispatcher.php(129): IPS\babble\modules\front\view\_view->execute() #11 /home/x/public_html/x/index.php(13): IPS\_Dispatcher->run() #12 {main} #0 /home/x/public_html/x/init.php(498): IPS\_Log::log('SELECT count(*)...', 'uncaught_except...') #1 /home/x/public_html/x/system/Helpers/Table/Table.php(477): IPS\IPS::exceptionHandler(Object(IPS\Db\Exception)) #2 /home/x/public_html/x/applications/babble/sources/Rooms/Rooms.php(231): IPS\Helpers\Table\_Table->__toString() #3 /home/x/public_html/x/applications/babble/modules/front/view/view.php(688): IPS\babble\_Rooms::buildRoomArchive(Object(IPS\babble\Rooms\Room)) #4 [internal function]: IPS\babble\modules\front\view\_view->roomArchive() #5 /home/x/public_html/x/system/Dispatcher/Controller.php(85): call_user_func(Array) #6 /home/x/public_html/x/applications/babble/modules/front/view/view.php(255): IPS\Dispatcher\_Controller->execute() #7 /home/x/public_html/x/system/Dispatcher/Dispatcher.php(129): IPS\babble\modules\front\view\_view->execute() #8 /home/x/public_html/x/index.php(13): IPS\_Dispatcher->run()
  8. Hi Michael! Sorry, I don't have an accurate step-by-step. However, when I deleted a couple of the alt accounts the member logs were still there. Then sometime after I clicked to remove the member entry, as their alt accounts were already deleted, and it was after that the member logs vanished. There were no system or program errors shown. As little this info was, I hope it helps in some way.
  9. I'm also having this issue, where I removed an alt account and it wiped out the logs. I uninstalled the app, deleted the files, and installed it but with same results. I cleared cache. No system errors At this time there are no logged duplicate accounts detected.
  10. I created an admin group to manage Babble in the ACP. The issue is that the group can't access the settings, like rooms, even when it's checked (see attachment), unless they have full admin rights. What is the permissions needed for an admin to access Babble rooms?
  11. YES! I added the file names and Babble is working now! You are a genius, Michael! Thank you!
  12. Happy New Year, Michael! These are the steps I did: ACP Port = Yes Node URL = https://mysite.com:3000 Enable SSL Context Options = ? I left it disabled babble.js var sslPrivateKey = /home/site/full_path/ var sslCertificate = /home/site/full_path/ Both full paths include trailing slash. Regenerated Private Key (also matched in babble.js). forever stopall and then restarted node.js I must be doing something wrong.
  13. I've entered: sslPrivateKey sslCertificate The 2 very long strings of text into babble.js. Unless of course I'm entering them wrong. What goes in these? var sslPrivateKey = ''; //ssl private.key file var sslCertificate = ''; //ssl certificate.crt file var sslBundle = ''; //ssl ca.cert file, not always required.
  14. Node URL = https://www.mysite.com:3000 I tried removing the port ":3000", and removing the "s" from http. I tried "localhost" instead of my domain. I've restarted node.js. None worked.
  15. I've been trying to get Babble working with SSL. I read through the documentations, but I must be missing something. "Babble is not connected to the node server, please contact the administrator!" What are the settings I need to do?